Gå til hovedindhold

Hvordan tælles antallet af store eller små bogstaver i cellen?

Hvordan kunne du hurtigt og nemt få antallet af store eller små bogstaver i en celle? I denne artikel vil jeg tale om nogle hurtige formler til kun at tælle antallet af store eller små bogstaver i tekststrenge.

Tæl antallet af store eller små bogstaver i cellen med formler


pil blå højre boble Tæl antallet af store eller små bogstaver i cellen med formler

Følgende formler kan hjælpe dig med kun at tælle store bogstaver eller små bogstaver i en celle, gør venligst som dette:

Tæl antallet af store bogstaver i en celle:

Indtast venligst denne formel:

=SUMPRODUKT(LEN(A2)-LEN(ERSTATNING(A2,CHAR(RÆKKE(INDIREKTE("65:90"))),""))) ind i en tom celle ved siden af ​​din datacelle for at finde resultatet, og træk derefter udfyldningshåndtaget ned til de celler, hvor du vil tælle de store bogstaver, og antallet af store bogstaver er blevet talt på én gang, se skærmbillede:

doc count stort 1

Tæl antallet af små bogstaver i en celle:

Indtast venligst denne formel:

=SUMPRODUKT(LEN(A2)-LEN(ERSTATNING(A2,CHAR(RÆKKE(INDIREKTE("97:122"))),""))) ind i en tom celle ved siden af ​​dine data, og træk derefter udfyldningshåndtaget ned til de celler, hvor du vil anvende denne formel, og alle små bogstaver i de tilsvarende celler er blevet talt som følgende skærmbillede vist:

doc count stort 2

Bedste kontorproduktivitetsværktøjer

Populære funktioner: Find, fremhæv eller identificer dubletter   |  Slet tomme rækker   |  Kombiner kolonner eller celler uden at miste data   |   Runde uden formel ...
Super opslag: VLookup med flere kriterier    Multiple Value VLookup  |   VOpslag på tværs af flere ark   |   Fuzzy Lookup ....
Avanceret rulleliste: Opret hurtigt rulleliste   |  Afhængig rulleliste   |  Multivælg rulleliste ....
Column Manager: Tilføj et bestemt antal kolonner  |  Flyt kolonner  |  Skift synlighedsstatus for skjulte kolonner  |  Sammenlign områder og kolonner ...
Fremhævede funktioner: Grid fokus   |  Designvisning   |   Stor Formel Bar    Arbejdsbog & Ark Manager   |  Ressourcebibliotek (Autotekst)   |  Datovælger   |  Kombiner regneark   |  Krypter/Dekrypter celler    Send e-mails efter liste   |  Superfilter   |   Specielt filter (filter fed/kursiv/gennemstreget...) ...
Top 15 værktøjssæt12 tekst Værktøj (tilføje tekst, Fjern tegn, ...)   |   50 + Chart Typer (Gantt kort, ...)   |   40+ Praktisk formler (Beregn alder baseret på fødselsdag, ...)   |   19 Indsættelse Værktøj (Indsæt QR-kode, Indsæt billede fra sti, ...)   |   12 Konvertering Værktøj (Tal til ord, Valutaomregning, ...)   |   7 Flet og del Værktøj (Avancerede kombinere rækker, Opdel celler, ...)   |   ... og mere

Overlad dine Excel-færdigheder med Kutools til Excel, og oplev effektivitet som aldrig før. Kutools til Excel tilbyder over 300 avancerede funktioner for at øge produktiviteten og spare tid.  Klik her for at få den funktion, du har mest brug for...

kte-fane 201905


Fanen Office bringer en grænseflade til et kontor med Office, og gør dit arbejde meget lettere

  • Aktiver redigering og læsning af faner i Word, Excel, PowerPoint, Publisher, Access, Visio og Project.
  • Åbn og opret flere dokumenter i nye faner i det samme vindue snarere end i nye vinduer.
  • Øger din produktivitet med 50 % og reducerer hundredvis af museklik for dig hver dag!
Comments (4)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
DurasovicOtto
có cách gì để tách Durasovic và Otto ra không
This comment was minimized by the moderator on the site
i dont understand how this works. how would you define the row(indirect("Range")) in VBA?
This comment was minimized by the moderator on the site
How can I count special characters/symbols please?
This comment was minimized by the moderator on the site
=LEN(I2)-LEN(SUBSTITUTE(I2,".",""))
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations