Note: The other languages of the website are Google-translated. Back to English

Hvordan finder man værdi i en celle med kommaadskilt liste i Excel?

Hvis du antager, at du har en kolonne, indeholder kommaseparerede værdier såsom Salg, 123, AAA, og nu vil du finde ud af, om værdi 123 i den kommaadskilte celle, hvordan kan du gøre det? Denne artikel introducerer metode til løsning af problemet.

Find værdi i en celle med en kommasepareret liste med formlen


Find værdi i en celle med en kommasepareret liste med formlen

Den følgende formel kan hjælpe dig med at finde værdi i en celle med kommaadskilt liste i Excel. Gør som følger.

1. Vælg en tom celle, indtast formlen =IF(ISNUMBER(SEARCH(123,A2)),"yes","no") ind i formellinjen, og tryk derefter på Enter-tasten. Se skærmbillede:

Bemærk: i formlen er A2 cellen indeholder de komma-adskilte værdier, du finder.

2. Bliv ved med at vælge resultatcellen, og træk udfyldningshåndtaget ned for at få alle resultater. Hvis værdien "123" er i de komma-adskilte celler, får du resultatet som "Ja"; Ellers får du resultatet som "Nej". Se skærmbillede:


Relaterede artikler:


De bedste Office-produktivitetsværktøjer

Kutools til Excel løser de fleste af dine problemer og øger din produktivitet med 80%

  • Genbruge: Indsæt hurtigt komplekse formler, diagrammer og alt, hvad du har brugt før; Krypter celler med adgangskode Opret postliste og send e-mails ...
  • Super formel bar (let redigere flere linjer med tekst og formel); Læsning Layout (let at læse og redigere et stort antal celler); Indsæt til filtreret rækkevidde...
  • Flet celler / rækker / kolonner uden at miste data; Split celler indhold; Kombiner duplikerede rækker / kolonner... Forhindre duplikerede celler; Sammenlign områder...
  • Vælg Duplicate eller Unique Rækker; Vælg tomme rækker (alle celler er tomme); Super Find og Fuzzy Find i mange arbejdsbøger; Tilfældig valg ...
  • Præcis kopi Flere celler uden at ændre formelreference; Auto Opret referencer til flere ark; Indsæt kugler, Afkrydsningsfelter og mere ...
  • Uddrag tekst, Tilføj tekst, Fjern efter position, Fjern mellemrum; Opret og udskriv personsøgningssubtotaler; Konverter mellem celler indhold og kommentarer...
  • Superfilter (gem og anvend filterskemaer på andre ark); Avanceret sortering efter måned / uge / dag, hyppighed og mere; Specielt filter af fed, kursiv ...
  • Kombiner arbejdsbøger og arbejdsark; Fletabeller baseret på nøglekolonner; Opdel data i flere ark; Batch Konverter xls, xlsx og PDF...
  • Mere end 300 kraftfulde funktioner. Understøtter Office / Excel 2007-2021 og 365. Understøtter alle sprog. Nem implementering i din virksomhed eller organisation. Fuld funktioner 30-dages gratis prøveperiode. 60 dages pengene tilbage garanti.
kte-fane 201905

Fanen Office bringer en grænseflade til et kontor med Office, og gør dit arbejde meget lettere

  • Aktiver redigering og læsning af faner i Word, Excel, PowerPoint, Publisher, Access, Visio og Project.
  • Åbn og opret flere dokumenter i nye faner i det samme vindue snarere end i nye vinduer.
  • Øger din produktivitet med 50 % og reducerer hundredvis af museklik for dig hver dag!
officetab bund
Sorter kommentarer efter
Kommentarer (16)
Ingen vurderinger endnu. Vær den første til at bedømme!
Denne kommentar blev minimeret af moderatoren på webstedet
Godmorgen til alle. Jeg har et excel-spørgsmål om, hvordan man tæller kommaseparerede specifikke værdier i en enkelt celle i excel. Jeg vil gerne tælle antallet af 15'ere i en enkelt celle, der indeholder 15,215,15,155,45,1515,15 Jeg har brug for resultat 3. Er der nogen formel i excel.
Denne kommentar blev minimeret af moderatoren på webstedet
Ja, der er en funktion i Excel, der kan gøre dette for dig. Men som forklaret i problemet ovenfor for at opnå bedre nøjagtighed for dine data, skal du tilføje et komma til venstre og højre for din liste og inkludere det i din søgning. Se eksempel nedenfor:
, 15,215,15,155,45,1515,15,
=ANTALHVIS(A1; ";15,"")
Forklaringen på denne formel er som følger: =ANTALHVIS(cellenummer eller område, værdi, du leder efter/tæller)
Sig til, hvis du har brug for et bedre eksempel.
Denne kommentar blev minimeret af moderatoren på webstedet
Hello!
Dette er en rigtig fed formel, men den har ... fejl? ... at jeg ikke kan finde ud af at omgå det. "Fejl" er ikke det rigtige ord, men jeg kan ikke komme i tanke om (det er 8:30 på mandag) på det rigtige ord.
Når du leder efter en del af et nummer, får du "ja". Så følgende returnerer alle "ja":
=HVIS(ERNUMMER(SØG(12;A2)),"ja","nej")
=HVIS(ERNUMMER(SØG(23;A2)),"ja","nej")
=HVIS(ERNUMMER(SØG(3;A2)),"ja","nej")

Jeg prøvede at pakke tallene ind i anførselstegn uden held. Formlen fungerer perfekt til eksemplets use case, hvor alle tallene er af samme længde. Men hvis du leder efter et kortere tal, der tilfældigvis dukker op i strengen, får du en falsk positiv.
Er der et alternativ til "SØG", der er mere bogstaveligt (igen, er det ordet? haha)? 
Tak! 
Denne kommentar blev minimeret af moderatoren på webstedet
Hej Scott S., mener du at søge efter den nøjagtige streng?
Denne kommentar blev minimeret af moderatoren på webstedet
Hej Crystal.
Ja, jeg formoder, at det er måden at formulere det på. 
Den aktuelle løsning vil returnere "Ja" for enhver del af talstrengen. Så tallene 1, 2, 3, 12, 23 og 123 vil alle returnere "Ja". 
Jeg har forsøgt at finde en løsning, der vil søge i en række af tal og returnere "Ja" for et nøjagtigt match. 
Denne kommentar blev minimeret af moderatoren på webstedet
Hej Scott S, tak for din feedback. Jeg har ikke fundet løsningen endnu og vender tilbage til dig, hvis jeg fandt den.
Denne kommentar blev minimeret af moderatoren på webstedet
Jeg har fundet en løsning på dette. Hvis du tilføjer et komma til venstre og højre på din liste og inkluderer dem (som en sandwich) i din søgning, vil det give dig mulighed for at finde et nøjagtigt match. Eksempel nedenfor:
, 123,231,321,122,321,1,2,3,23,
SØG(",23,"")
På denne måde tvinger det søgningen til at matche fra det ene komma til det andet i stedet for blot en del af posten fra listen. Håber det er det du ledte efter?
Denne kommentar blev minimeret af moderatoren på webstedet
Jeg har fundet en løsning. Hvis du tilføjer et komma til venstre og højre på din liste, vil det kræve søgefunktionen for at finde et nøjagtigt match fra komma til komma. Se eksempel nedenfor:
=HVIS(ERNUMMER(SØG(",12,"A2)),"ja","nej")

, 312,123,10,112,126,
Dette vil returnere falsk, fordi der ikke er nogen variabel fra komma til komma (,12,), der matcher søgningen. 
Hvis du har brug for yderligere afklaring, så lad mig det vide og send et bedre eksempel. Jeg havde det samme problem, da jeg automatiserede en rapport til min chef og havde en åbenbaring. :)
Denne kommentar blev minimeret af moderatoren på webstedet
Hej, jeg kan stadig ikke finde ud af det. Jeg har stadig det samme problem. i stedet for at bruge tal i formlen bruger jeg en cellereference. for eksempel hvis jeg søger efter "1"(Q$1) i (123, 25,29,200)($J2), giver det mig stadig JA. Formlen er =HVIS(ER TAL(SØG(Q$1,$J2)),"ja","nej")

PS: Jeg har et stort datasæt, som jeg ikke kan sætte kommaer før og efter i hver celle. Vil sætte pris på en løsning
Denne kommentar blev minimeret af moderatoren på webstedet
Hej Hjælp venligst

Jeg har tabel i Excel med to kolonner A & B, under A er der værdi F.eks. A2 Celle har 1,2,2,1,2,1,2 osv. (har kun to tal 1 og 2, men skal genkende den kun har 1 & 2 i hele cellen og intet andet tal) og A3 har 1,1,1 og A4 har 0, A5 har 2,2,2,2 og A6 har 20. Jeg vil have, at B2 skal returnere værdien for A2 som Asien , B3 Afrika, B4 som Ingen, B5 som Amerika og B6 som Europa. Jeg troede, jeg kunne bruge if-formlen, men den er ikke i stand til at genkende kommaseparerede tal og returneringsværdi). Hjælp venligst
Denne kommentar blev minimeret af moderatoren på webstedet
Hvad med dette venligst, jeg er nødt til at få værdierne i A og sidestille dem med tallene i C og returnere værdierne i B adskilt som i kommaer til C.

Tak
Denne kommentar blev minimeret af moderatoren på webstedet
Hej duncan,
Hvis du bruger Excel til 365, kan følgende formel hjælpe med at løse problemet.
=TEXTJOIN(",",TRUE,XLOOKUP(TRANSPOSE(VALUE(TEXTSPLIT(D1,","))),A1:A3,B1:B3,"",0,1))
Denne formel virker kun i Excel til 365. For andre Excel-versioner end Excel til 365, har jeg ikke fundet en formel, der håndterer det..
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/find-value.png
Denne kommentar blev minimeret af moderatoren på webstedet
Hej alle, jeg har en celle, der har flere lande adskilt af kommaer
Eksempel: A2-celleværdi er (Indien, Japan, Malaysia, Greater China)
Kolonne G har landenavnene
Nu skal jeg finde en formel, der sammenligner værdi fra kolonne G med værdi i A2-celle.
Hvis værdien matcher, returner true ellers False
Denne kommentar blev minimeret af moderatoren på webstedet
Hej Mohini Verma,
Formlen kan ændres som følger:
=HVIS(ER TAL(SØG(G2,A2)),"SAND","FALSK")
Denne kommentar blev minimeret af moderatoren på webstedet
Hej, jeg kan stadig ikke finde ud af det. Jeg har stadig det samme problem. i stedet for at bruge tal i formlen bruger jeg en cellereference. for eksempel hvis jeg søger efter "1"(Q$1) i (123, 25,29,200)($J2), giver det mig stadig JA. Formlen er =HVIS(ER TAL(SØG(Q$1,$J2)),"ja","nej")

PS: Jeg har et stort datasæt, som jeg ikke kan sætte kommaer før og efter i hver celle. Vil sætte pris på en løsning
Denne kommentar blev minimeret af moderatoren på webstedet
Hej Hassam

Brug blot følgende formel uden HVIS-funktionen. Hvis tallet matcher nøjagtigt, får du resultatet "TRUE", ellers får du resultatet"FALSK".
=ISNUMBER(FIND(",1,",","&$J2&","))
https://www.extendoffice.com/images/stories/comments/comment-picture-zxm/match.png
Der er endnu ingen kommentarer her
Efterlad dine kommentarer
Sender som gæst
×
Bedøm dette indlæg:
0   Tegn
Foreslåede steder

Følg os

Copyright © 2009 - www.extendoffice.com. | Alle rettigheder forbeholdes. Drevet af ExtendOffice. | | Sitemap
Microsoft og Office-logoet er varemærker eller registrerede varemærker tilhørende Microsoft Corporation i USA og / eller andre lande.
Beskyttet af Sectigo SSL