Note: The other languages of the website are Google-translated. Back to English

Hent n'te match med INDEX

For at finde det n'te match af en værdi fra et område og hente dets tilsvarende data, kan du bruge en formel baseret på INDEX, RÆKKE, LILLE og IF funktioner.

hente n'te match med indeks 1

Hvordan henter man information forbundet med det n'te match af en værdi med INDEX?

At hente oplysninger om Usain Bolts 3. kamp i tabellen som vist ovenfor, kan du bruge ROW- og IF-funktionerne sammen for at få et array, der består af rækkenumrene for alle Usain Bolt-værdierne. Brug derefter SAMLL-funktionen til at hente rækkenummeret for den n'te matchede værdi, du har angivet. Til sidst skal du føre resultatet til INDEX-funktionen for at få den tilsvarende information i samme række.

Generisk syntaks

=INDEX(return_range,SMALL(IF(lookup_array=lookup_value,ROW(lookup_array-ROW(INDEX(lookup_array,1,1))+1),n))

√ Bemærk: Dette er en matrixformel, der kræver, at du indtaster med Ctrl + Flytte + Indtast.

  • returområde: Det interval, der skal returneres oplysningerne svarende til det n'te match fra. Her refererer til året eller tidsinterval.
  • opslag_array: Området, der skal ledes efter rækkepositionen for den n'te kamp fra. Her refererer til vinderrækken.
  • opslagsværdi: Den værdi, du har angivet for at finde dets n'te match. Her refererer til Usain Bolt.
  • n: Angiv den n'te kamp. For at finde det første match af en værdi skal du indstille n som 1; for at finde den 2. kamp, ​​sæt n som 2.

At hente oplysninger om Usain Bolts 3. kamp, kopier eller indtast formlerne nedenfor i cellerne G8 og G9, og tryk Ctrl + Flytte + Indtast for at få resultaterne:

År (celle G8)
= INDEX (B6: B12,SMALL(HVIS(C6: C12=G5,RÆKKE(C6: C12-RÆKKE(INDEKS(C6: C12,1,1))+1),G6))
Tid (celle G9)
= INDEX (D6: D12,SMALL(HVIS(C6: C12=G5,RÆKKE(C6: C12-RÆKKE(INDEKS(C6: C12,1,1))+1),G6))

hente n'te match med indeks 2

Forklaring af formlen

Her bruger vi formlen herunder som et eksempel:

=INDEX(B6:B12,SMALL(IF(C6:C12=G5,ROW(C6:C12)-ROW(INDEX(C6:C12,1,1))+1),G6))

  • RÆKKE(C6:C12): Funktionen RÆKKE returnerer rækkenumrene for hver celle i området C6: C12 i et array som dette: {6;7;8;9;10;11;12}.
  • RÆKKE(INDEKS(C6:C12,1,1;XNUMX;XNUMX)): Funktionerne INDEX og ROW returnerer det første rækkenummer i opslagsområdet C6: C12 i dette Excel regneark, som er 6.
  • HVIS(C6:C12=G5,RÆKKE(C6:C12)-RÆKKE(INDEKS(C6:C12,1,1;XNUMX;XNUMX))+ 1) = HVIS(C6:C12=G5,{6;7;8;9;10;11;12}-6+ 1): HVIS-funktionen kontrollerer, om hver værdi i området C6: C12 matcher værdien i cellen G5, Usain Bolt. Hvis ja, vil funktionen returnere resultatet af "dens tilsvarende række nummer-6+1"; Ellers returner en FALSK. Så resultaterne ville være i et array som dette: {FALSK;2;3;4;FALSK;FALSK;FALSK}.
  • LILLE(HVIS(C6:C12=G5,RÆKKE(C6:C12)-RÆKKE(INDEKS(C6:C12,1,1;XNUMX;XNUMX))+ 1),G6) = LILLE({FALSK;2;3;4;FALSK;FALSK;FALSK},G6): Uddraget returnerer 3rd (værdi i celle G6) mindste værdi fra arrayet, som er 4.
  • INDEKS(B6:B12;LILLE(HVIS(C6:C12=G5,RÆKKE(C6:C12)-RÆKKE(INDEKS(C6:C12,1,1;XNUMX;XNUMX))+ 1),G6)) = INDEKS(B6:B12;4) INDEX -funktionen returnerer 4værdi i årrækken B6: B12, Hvilket er Beijing 2008.

Relaterede funktioner

Excel INDEX-funktion

Excel INDEX -funktionen returnerer den viste værdi baseret på en given position fra et område eller en matrix.

Excel IF-funktion

IF-funktionen er en af ​​de enkleste og mest nyttige funktioner i Excel-projektmappe. Den udfører en simpel logisk test, som afhænger af sammenligningsresultatet, og den returnerer en værdi, hvis et resultat er SAND, eller en anden værdi, hvis resultatet er FALSK.

Excel ROW-funktion

Excel ROW-funktionen returnerer række nummeret for en reference.


Relaterede formler

Hent n'te match med VLOOKUP

Antag, at du har en liste over værdier og deres tilsvarende information, for at hente den relaterede information om den n'te match af en værdi, kan du bruge en formel baseret på SLAGOPSLAG-funktionen.

Hent information forbundet med laveste n værdier

For at hente data, der svarer til den mindste, 2. mindste eller n. mindste værdi i en liste, tabel eller række i Excel, kan du bruge en INDEX- og MATCH-formel sammen med SMALL-funktionen.

Få information svarende til maksimal værdi

For at hente data, der svarer til den maksimale værdi i en liste, tabel eller række i Excel, kan du bruge en INDEX- og MATCH-formel sammen med MAX-funktionen.

Få information svarende til minimumsværdi

For at hente data, der svarer til minimumsværdien i en tabel, kan du bruge en INDEX- og MATCH-formel sammen med MIN-funktionen.


De bedste Office-produktivitetsværktøjer

Kutools til Excel - Hjælper dig med at skille dig ud fra mængden

Kunne du tænke dig at udføre dit daglige arbejde hurtigt og perfekt? Kutools til Excel bringer 300 kraftfulde avancerede funktioner (Kombiner projektmapper, sum efter farve, delt celleindhold, konverter dato, og så videre...) og spar 80% tid for dig.

  • Designet til 1500 arbejdsscenarier, hjælper dig med at løse 80 % Excel-problemer.
  • Reducer tusindvis af tastatur- og museklik hver dag, lindre dine trætte øjne og hænder.
  • Bliv en Excel-ekspert på 3 minutter. Behøver ikke længere huske smertefulde formler og VBA-koder.
  • 30-dages ubegrænset gratis prøveperiode. 60-dages pengene tilbage garanti. Gratis opgradering og support i 2 år.
Ribbon of Excel (med Kutools til Excel installeret)

Fanen Office - Aktiver læsning og redigering af faner i Microsoft Office (inkluderer Excel)

  • Et sekund til at skifte mellem snesevis af åbne dokumenter!
  • Reducer hundreder af museklik for dig hver dag, og farvel med musens hånd.
  • Øger din produktivitet med 50 %, når du ser og redigerer flere dokumenter.
  • Bringer effektive faner til Office (inkluderer Excel), Ligesom Chrome, Firefox og ny Internet Explorer.
Skærmbillede af Excel (med Office-fanen installeret)
Sorter kommentarer efter
Kommentarer (0)
Ingen vurderinger endnu. Vær den første til at bedømme!
Der er endnu ingen kommentarer her
Efterlad dine kommentarer
Sender som gæst
×
Bedøm dette indlæg:
0   Tegn
Foreslåede steder

Følg os

Copyright © 2009 - www.extendoffice.com. | Alle rettigheder forbeholdes. Drevet af ExtendOffice. | | Sitemap
Microsoft og Office-logoet er varemærker eller registrerede varemærker tilhørende Microsoft Corporation i USA og / eller andre lande.
Beskyttet af Sectigo SSL