Note: The other languages of the website are Google-translated. Back to English

Sum de mindste eller nederste N -værdier i Excel

I Excel er det nemt for os at summere en række celler ved at bruge SUM-funktionen. Nogle gange skal du muligvis summere de mindste eller nederste 3, 5 eller n tal i et dataområde som vist nedenfor. I dette tilfælde kan SUMPRODUKTET sammen med SMALL-funktionen hjælpe dig med at løse dette problem i Excel.


Sum mindste eller nederste N værdier med SUMPRODUCT og SMALL funktioner

For at summere det mindste n tal i et dataområde kan du finde de mindste n tal ved at bruge SMALL-funktionen og derefter anvende SUMPRODUCT-funktionen til at summere matrixlisten direkte, den generiske syntaks er:

=SUMPRODUCT(SMALL(range,{1,2,…,N}))
  • range: Området af celler indeholder de tal, der skal summeres;
  • N: Repræsenterer den N. bundværdi.

Her vil jeg summere de laveste 4 tal i området B2:B12, indtast eller kopier nedenstående formel ind i en tom celle, og tryk Indtast nøgle for at få resultatet:

=SUMPRODUCT(SMALL(B2:B12,{1,2,3,4}))


Forklaring til formlen:

=SUMPRODUKT(SMÅ(B2:B12;{1,2,3,4;XNUMX;XNUMX;XNUMX}))

  • SMALL(B2:B12;{1,2,3,4;XNUMX;XNUMX;XNUMX}):Denne LILLE-funktion bruges til at returnere den 1., 2., 3. og 4. mindste værdi i området B2:B12. Du får arrayet sådan her: {200,230,345,560}.
  • SUMPRODUKT(SMÅ(B2:B12;{1,2,3,4;200,230,345,560;XNUMX;XNUMX}))=SUMPRODUKT({XNUMX;XNUMX;XNUMX}): SUMPRODUKT-funktionen summerer alle tal i matrixlisten for at få resultatet:1335.

Tips: Løsning, når N bliver stor:

Nogle gange kan du have en stor liste med tal, for at summere de mindste 50 eller flere tal i intervallet, vil det være kedeligt at indtaste tallet 1,2,3,4...50 i SMALL-funktionen. Så her kan du bruge funktionerne ROW og INDIREKTE til at skabe matrixkonstanten.

For at summere de laveste 10 værdier i et interval, skal du f.eks. anvende nedenstående formler:

Manuel indtastning af et tal:

=SUMPRODUCT(SMALL(B2:B15,ROW(INDIRECT("1:10"))))

Brug en cellereference:

=SUMPRODUCT(SMALL(B2:B15,ROW(INDIRECT("1:"&D2))))


Relativ funktion anvendt:

  • SUMPRODUCT:
  • SUMPRODUCT-funktionen kan bruges til at gange to eller flere kolonner eller arrays sammen og derefter få summen af ​​produkter.
  • SMALL:
  • Excel SMALL-funktionen returnerer en numerisk værdi baseret på dens position på en liste, når den sorteres efter værdi i stigende rækkefølge.

Flere artikler:

  • Sum mindste eller nederste N-værdier baseret på kriterier
  • I tidligere selvstudie har vi diskuteret, hvordan man summerer de mindste n værdier i et dataområde. I denne artikel vil vi udføre en yderligere avanceret operation - at summere de laveste n værdier baseret på et eller flere kriterier i Excel.
  • Subtotale fakturabeløb efter alder i Excel
  • For at summere fakturabeløbene baseret på alder, som det viste skærmbillede kan være en almindelig opgave i Excel, vil denne vejledning vise, hvordan du subtotaler fakturabeløb efter alder med en normal SUMIF-funktion.
  • Sum alle antal celler ignorerer fejl
  • Når man summerer et område af tal, som indeholder nogle fejlværdier, vil den normale SUM-funktion ikke fungere korrekt. For kun at summere tal og springe fejlværdierne over, kan AGGREGATE-funktionen eller SUM sammen med IFERROR-funktionerne gøre dig en tjeneste.

De bedste Office-produktivitetsværktøjer

Kutools til Excel - Hjælper dig med at skille dig ud fra mængden

Kunne du tænke dig at udføre dit daglige arbejde hurtigt og perfekt? Kutools til Excel bringer 300 kraftfulde avancerede funktioner (Kombiner projektmapper, sum efter farve, delt celleindhold, konverter dato, og så videre...) og spar 80% tid for dig.

  • Designet til 1500 arbejdsscenarier, hjælper dig med at løse 80 % Excel-problemer.
  • Reducer tusindvis af tastatur- og museklik hver dag, lindre dine trætte øjne og hænder.
  • Bliv en Excel-ekspert på 3 minutter. Behøver ikke længere huske smertefulde formler og VBA-koder.
  • 30-dages ubegrænset gratis prøveperiode. 60-dages pengene tilbage garanti. Gratis opgradering og support i 2 år.
Ribbon of Excel (med Kutools til Excel installeret)

Fanen Office - Aktiver læsning og redigering af faner i Microsoft Office (inkluderer Excel)

  • Et sekund til at skifte mellem snesevis af åbne dokumenter!
  • Reducer hundreder af museklik for dig hver dag, og farvel med musens hånd.
  • Øger din produktivitet med 50 %, når du ser og redigerer flere dokumenter.
  • Bringer effektive faner til Office (inkluderer Excel), Ligesom Chrome, Firefox og ny Internet Explorer.
Skærmbillede af Excel (med Office-fanen installeret)
Sorter kommentarer efter
Kommentarer (0)
Ingen vurderinger endnu. Vær den første til at bedømme!
Der er endnu ingen kommentarer her
Efterlad dine kommentarer
Sender som gæst
×
Bedøm dette indlæg:
0   Tegn
Foreslåede steder

Følg os

Copyright © 2009 - www.extendoffice.com. | Alle rettigheder forbeholdes. Drevet af ExtendOffice. | | Sitemap
Microsoft og Office-logoet er varemærker eller registrerede varemærker tilhørende Microsoft Corporation i USA og / eller andre lande.
Beskyttet af Sectigo SSL